07 March 2010

you can't get there from here

youtube has a nice warning system in place, letting me know recently that my version of Firefox would soon no longer be supported by their site. And they made some recommendations, including FF 3.5.

so i went to see what version of FF i was running on my (vintage 2004) ibook: FF

okay, that's a little old, let me go to "Help / Check for Updates..." and see what I can get. Mozilla makes it easy to upgrade FF versions, downloading/installing in one step and even restoring your open windows. nice touch.

it updated me to 3.0.15. Not even close to the 3.5 I would need to keep using youtube. At this point, I began to get a little worried that my hardware, and OS (Tiger), are a little too outdated to run the latest of FF.

So back to "Help / Check for Updates" and BAM it installed 3.0.18 for me. Try again: BAM now I have 3.6. Try again: I'm at the latest.

I assume there's a good technical reason that i couldn't go straight from to 3.6, but I'd love to know what it is.

Now when is that damn Macbook Pro refresh coming?

1 comment:

pyker said...

Hey, I just tried it. It updated me from 3.0.11 to 3.0.18 before then deciding I was worthy to go to 3.6